Exchange-Server-Cumulative-Update

Exchange Server 2016 Cumulative Update 9

A Microsoft lançou o Cumulative Update 9 para Exchange Server 2016 em março de 2018. O Update possui o build number 15.01.1466.003.

Uma novidade referente do então lançamento do CU9 foi:

  • O TLS 1.2 agora é suportado em todas as versões do Exchange Server. Haverá orientações adicionais da Microsoft sobre este assunto. Todavia o primeiro post desta série já está disponível.

O CU9 foi lançado também com o propósito de corrigir os seguintes problemas:

  • 4058297Hybrid free/busy lookups fail between Exchange Server 2016 CU8 and O365
  • 4099849Can’t remove a mobile device through OWA options in Exchange Server 2016
  • 4054513Mailbox usage status bar in OWA displays incorrect mailbox usage
  • 4055433User is added to an entire series when accepting a single instance through Exchange ActiveSync
  • 4057216Health mailbox’s password is exposed in logs for a failed probe in Exchange Server 2016 and 2013
  • 4058373“A parameter cannot be found” error when you run Install-AntiSpamAgents.ps1 in Exchange Server 2016 CU7
  • 4058379All cross-forest meeting updates have to be accepted again in Exchange Server 2016 and 2013
  • 4058383Exchange Control Panel (ECP) redirection fails in Exchange Server 2016
  • 4058384Get-CalendarDiagnosticAnalysis shows DateTime in 12-hour clock in Exchange Server 2016 and 2013
  • 4058399Disabling a mailbox can’t remove legacyExchangeDN from user’s properties in Exchange Server 2016
  • 4073094Emails outside a UID range are returned when you request for emails by using IMAP
  • 4073095“550 5.6.0 CAT.InvalidContent.Exception” and email isn’t delivered in Exchange Server 2016 and 2013
  • 4073104PIN can be reset on a Unified Messaging (UM)-enabled mailbox for a user outside a scoped OU
  • 4073103The Enable-Mailbox cmdlet doesn’t block migrated users from provisioning in Exchange Server 2016
  • 4073107Language can’t be changed when a user from a child domain tries to change language in OWA
  • 4073111Can’t access a CAS website such as OWA/ECP/Autodiscover in Exchange Server 2016
  • 4073110You can’t access OWA or ECP after you install Exchange Server 2016 CU8

  • 4073109Search-MailboxAuditLog -ShowDetails not showing all messages in Exchange Server 2016
  • 4073114“ADOperationException” error when OWA text verification fails in Exchange Server 2016
  • 4073214Can’t enable OWA offline access in Exchange Server 2016
  • 4073531CultureNotFoundException when selecting a LCID 4096 language in OWA for Exchange Server 2016
  • 4076520MatchSubdomains isn’t usable for Set-AcceptedDomain in Exchange Server 2016
  • 4076741Incorrect NDR when an administrator deletes a message from a queue in Exchange Server 2016
  • 4077655Event ID 258 “Unable to determine the installed file” after you uninstall Windows PowerShell 2.0
  • 4057290Incorrect user is returned in the ECP when one user’s display name matches another user’s alias
  • 4058372Blank page in Exchange Admin Center Audit Log in Exchange Server 2016
  • 4058382Can’t retrieve time slot information about private calendar items as a delegate on another user’s account in Exchange Server 2016
  • 4058401Administrator audit logging does not record Set-ServerComponentState cmdlet details in Exchange Server 2013 or 2016 environment
  • 4073097Monitoring probes of ECP.Proxy health checks fail on all CAS roles in Exchange Server 2013 and 2016
  • 4073098The ETS and EXS groups are incorrectly granted “SeDebugPrivilege” in Exchange Server 2016 on-premises
  • 4073108“There was a problem loading your options” error when a user accesses OWA Voice Mail options in Exchange Server 2016
  • 4077924Store Worker process crashes when you move, restore, or repair mailboxes that have issues with the logical index within the database in Exchange Server 2016
  • 4091453Update improves linguistics features and CJK handling for search in Exchange Server 2016
  • 4073392Description of the security update for Microsoft Exchange: March 13, 2018

Requisitos:

  • O Cumulative Update 9 possui o mesmo requisito de instalação que o CU8 e CU7, o mesmo suporta similarmente apenas nível funcional de floresta e domínio 2008R2 ou superior. Portanto, caso ainda haja Domain Controller 2008 no ambiente, planeje o upgrade antes de aplicá-lo.
  • O Cumulative Update 9 não suporta o .NET Framework 4.7
  • O Cumulative Update 9 suporta a instalação do .NET Framework 4.7.1. Instale o CU9 e posteriormente instale o .NET Freamwork 4.7.1, cuja o qual será um requisito no próximo release CU10 em junho de 2018.

Problemas Constatados:

  • Logo após instalar o Cumulative Update 9 o botão “Accept” (Aceitar) desaparece dos e-mails de invite (convite) de um calendário compartilhado no Outlook Web App (OWA). Portanto, não é possível adicionar o calendário compartilhado clicando no botão “Aceitar” diretamente. Dessa forma, para contornar esse problema, pode-se usar um dos seguintes métodos:
    • Abrir o invite através do painel de Notificações do OWA;
    • Adicionar o calendário compartilhado manualmente através do OWA;
    • Abrir o invite através do Outlook e adicionar o calendário compartilhado.
  • Erro ao abrir mailbox com Full Access no OWA utilizando uma conta do AD que não possui mailbox. Relatei sobre esse problema nesse artigo.
  • Algumas Inbox-Rules – regras configuradas pelo Outlook, OWA ou Exchange – não funcionam. Não consegui realizar testes em mais de um Exchange CU9 para evidenciar se é um problema aleatório ou não, no entanto nos meus testes pude notar que as seguintes Inbox-Rules não funcionam:
    • Rule de Forward
    • Rule de Redirect

bug-cumulative update 9

  • Comando de Get-MailboxTransportService não traz modificações realizadas. Evidenciei esse bug ao habilitar o Pipeline Tracing, mesmo após habilitado o resultado me mostrava como se não estivesse habilitado:

bug-cumulative update 9

Vale a pena a instalação?

Eu acredito que vale sim a pena instalá-lo, desde que os problemas mencionados aqui não sejam um empecilho eu teu ambiente. Esse Cumulative Update 9 veio de fato para corrigir inúmeros bugs relacionados ao Cumulative Update 8, portanto nos casos em que estejas sendo afetado por algum bug proveniente do CU8, vale sim a pena instalá-lo o quanto antes. Ademais, certifique-se de realizar testes em teu ambiente antes de instalar o CU9 em produção.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *