Erro no Outlook 2010 ao acessar Public Folder: Cannot expand the folder. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance. Outlook 2013/2016 a Public Folder não aparece.

Após o migrar a Public Folder do Exchange 2007 ao Exchange 2013, alguns usuários  relataram problemas ao acessa-la a partir do Outlook 2010, Outlook 2013 ou Outlook 2016. O erro no Outlook 2010 era: Cannot expand the folder. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance. Ja no Outlook 2013 e 2016 a Public Folder nem mesmo era visivel.

Estranhamente o erro não ocorria a todos os usuários, para alguns sim e outros não, e não existia um padrão. O único padrão realmente encontrado foi que no OWA o acesso funcionava a todos.

No teste de AutoDiscover, o valor do atributo <PublicFolderInformation> <SmtpAddress> era correto a todos:  Mailbox1@dominio.com

<PublicFolderInformation>

Troubleshooting:

Realizei testes da seguinte maneira:

Usuário A com Outlook 2013: Apresentava problema.

Usuário B com Outlook 2013: Não apresentava problema

Teste 1 – No PC do usuário A, com sua conta do AD logada, criei um novo perfil de Outlook para o usuário B. A Public Folder do usuário B não apareceu.

Teste 2 – No PC do usuário B, com sua conta do AD logada, criei um novo perfil de Outlook para o usuário A. A Public Folder do usuário B apareceu.

Teste 3 – No PC do usuário A, realizei o logoff e loguei com o a conta do AD do usuário B, e criei um novo perfil de Outlook. A Public folder no usuário A não apareceu.

Teste 4 – No PC do usuário B, realizei o logoff e loguei com o a conta do AD do usuário A, e criei um novo perfil de Outlook. A Public folder no usuário A apareceu.

Esses testes me deixaram a ideia clara de que o problema não era vinculado ao PC ou ao Outlook, e sim ao perfil do Windows do usuário. Então tive a ideia de fazer um comparativo entre os atributos do AD dos usuários A e B, e bingo! Havia um atributo em comum que todos os usuários que apresentavam o problema, o possuíam: msExchQueryBaseDN

Resolução:

Após realizar alguns testes removendo o atributo msExchQueryBaseDN dos usuários problemáticos e ter absoluta certeza que o problema era aquele, era hora de partir para o modo bulk e alterar o atributo de todos que o possuíam.

Para isso, contei com a ajuda da boa e velha ferramenta chamada ADMODIFY.net. Com ela eu selecionei todo o meu domínio, e realizei a alteração do atributo inserindo o valor null:

ADMODIFY.net

Após isso, o problema foi sanado e a Public Folder ficou disponível a todos.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *